FreeBSD Daily Topics

2009年9月11日 Ports Collection - KDE 4.3.1,Opera 10.00,OpenOffice 3.1.1/2.4.3,JDK 16/15/14 (tzupdater 1.3.18),FreeBSD 7/6/5互換ライブラリ

この記事を読むのに必要な時間:およそ 0.5 分

ports

KDE 4.3.1

Ports Collectionに収録されているKDE 4系がKDE 4.3.1対応へとアップグレードされました。バグ修正や翻訳の更新などが実施されたメンテナンスアップデートとされています。

www/opera
www/opera-deve
www/linux-opera

Operaおよびinux OperaのportがOpera 10.00対応へアップグレードされました。これに伴い,従来10.00へ向けた開発版がエントリされていたOpera開発版のport(www/opera-devel)は必要性がなくなったことからIGNORE指定へ変更されました。

editors/openoffice.org-3
editors/openoffice.org-2

OpenOffice.org 3のportが3.1.1対応へアップグレードされた他,OpenOffice.org 2のportが2.4.3対応へアップグレードされました。

java/diablo-jdk16
java/diablo-jre16
java/diablo-jdk15
java/diablo-jre15
java/jdk16
java/jdk15
java/jdk14

Diablo JDK 16,Diablo JRE16,Diablo JDK15,Diablo JRE15,JDK16,JDK15,JDK14に対応したportがtzupdater 1.3.18を使うようにアップグレードされました。アップグレードするには出力されるメッセージに従い,tzupdater 1.3.18バイナリファイルをダウンロードして/usr/ports/distfiles/にコピーしてからアップグレード作業を実施する必要があります。

misc/compat7x
misc/compat6x
misc/compat5x

スレッド関連処理が適切に処理されるようにFreeBSD 7互換ライブラリ対応port(misc/compat7x),FreeBSD 6互換ライブラリ対応port(misc/compat6x),FreeBSD 5互換ライブラリ対応port(misc/compat5x)が更新されました。FreeBSD 8やFreeBSD 9で,FreeBSD 5/6/7向けに構築されたバイナリを実行するにはこれらからインストールされるライブラリが必要です。

コメント

コメントの記入