FreeBSD Daily Topics

2010年4月21日 libgmp4からgmpへアップグレードする方法

この記事を読むのに必要な時間:およそ 0.5 分

ports

libgmp4 going to gmp

Ports Collectionにおけるデフォルトのgmpライブラリが4系(math/libgmp4)から5系(math/gmp)へアップグレードされました。portupgrade -aを実行してgmpとlibgmp4がコンフリクトするためインストールできないといったエラーが出力される場合,このアップグレードに原因があります。

こうした問題に遭遇した場合,次のように先にlibgmp4をgmpへアップグレードしてから,通常のアップグレード作業を行ってください。

portupgrade(1)を使ってlibgmp4をgmpへアップグレードする方法

portupgrade -f -o math/gmp libgmp-4.3.2

コメント

コメントの記入